Project

General

Profile

Task #1777

Serialization of write operation in socket stream

Added by Alex Afanasyev about 5 years ago. Updated about 5 years ago.

Status:
Closed
Priority:
Normal
Category:
Faces
Target version:
Start date:
07/18/2014
Due date:
% Done:

100%

Estimated time:

Description

NFD has problem similar to one in issue #1769: async_send is not guaranteed to send all the supplied data and async_write should be used instead. However, async_write requires that no other async_write's are called until the first one finished. This implies that we need to serialize send() operations in at least StreamFace (datagram face may work as is).

The problem is not too critical, as it manifested itself so far only with UnixSockets, when transmitted packet was larger than 8192 bytes.

If solution is too complex, for 0.2 release we may just document the issue and really fix the problem in the next release.


Related issues

Related to ndn-cxx - Bug #1769: "error while connecting to forwarder" when using Face.put in a loop on large amount of dataAbandoned2014-07-16

History

#1 Updated by Alex Afanasyev about 5 years ago

  • Status changed from New to Code review
  • Assignee set to Alex Afanasyev
  • % Done changed from 0 to 100

#2 Updated by Alex Afanasyev about 5 years ago

  • Related to Bug #1769: "error while connecting to forwarder" when using Face.put in a loop on large amount of data added

#3 Updated by Alex Afanasyev about 5 years ago

  • Status changed from Code review to Closed
  • Target version changed from v0.2 to v0.3

Also available in: Atom PDF