Project

General

Profile

Bug #2479

Prefix discovery protocol: change Name of routable-prefixes packet

Added by Alex Afanasyev over 4 years ago. Updated about 4 years ago.

Status:
Closed
Priority:
Normal
Assignee:
Category:
Protocol
Target version:
Start date:
Due date:
% Done:

100%

Estimated time:
0.50 h

Description

Local prefix discovery protocol is now defined here: http://named-data.net/doc/NFD/current/misc/local-prefix-discovery.html

Essentially, hub publishes data packet with /localhop/ndn-autoconf/routable-prefixes prefix. However, this prefix is not registered (permanently) and should not be registered (permanently) by ndn-autoconfig client.

The protocol needs to be changed, so such prefix is published under /localhop/nfd or some other prefix that match prefix permanently registered during run of ndn-autoconfig.


Related issues

Related to NFD - Feature #3145: Collect and publish routable-prefixesNew

Blocks NFD - Feature #2512: ndn-autoconf-server: publish routable-prefixes as a StatusDatasetClosed2015-02-162015-02-18

History

#1 Updated by Junxiao Shi over 4 years ago

Local prefix discovery protocol is now defined here: http://named-data.net/doc/NFD/current/misc/local-prefix-discovery.html

Is HubDiscovery wiki page deprecated?

If so, clear the contents and replace with a link to the canonical page.

Essentially, hub publishes data packet with /localhop/ndn-autoconf/routable-prefixes prefix. However, this prefix is not registered (permanently) and should not be registered (permanently) by ndn-autoconfig client.

The protocol needs to be changed, so such prefix is published under /localhop/nfd or some other prefix that match prefix permanently registered during run of ndn-autoconfig.

Are you suggesting that routable-prefixes should be published under a prefix owned by NFD Management protocol?

I suggest using /localhop/nfd/rib/routable-prefixes. The rib component reflects that the set of routable prefixes is a property of the RIB on the gateway router.

In impl, ndn-autoconf-server can create Route /localhop/nfd/rib/routable-prefixes with CAPTURE flag.

#2 Updated by Alex Afanasyev over 4 years ago

Hub discovery wiki is not related to discovery of routable prefixes. As of right now, it is just a copy of the documentation and doesn't contradicts (rather combines several) NFD manpages.

I'm ok with any prefix. /localhop/nfd/rib/routable-prefixes could be ok

#3 Updated by Junxiao Shi over 4 years ago

ndn:/localhop/nfd is the namespace for NFD Management protocol. If routable-prefixes is under this namespace, it should be published as a StatusDataset.

diff from ndn:/localhop/ndn-autoconf/routable-prefixes is: Data Name has a segment number component.

On a higher level, fetching routable-prefixes Data packet doesn't need a Route. Instead, NextHopFaceId can be used to direct the Interest to the multicast face.

#4 Updated by Junxiao Shi over 4 years ago

  • Subject changed from Prefix discovery protocol needs an update to Prefix discovery protocol: change Name of routable-prefixes packet
  • Assignee set to Junxiao Shi
  • Target version changed from v0.3 to v0.4
  • Estimated time set to 0.50 h

20150211 conference call approves the idea in note-3.

This solution can only support one connected gateway router.

The eventual solution could be:

  1. gateway router exposes its management API under ndn:/localhop/spurs/nfd instead of ndn:/localhop/nfd
  2. tunnel authentication protocol discovers the prefix of gateway router ('spurs' in the example); tunnel authentication protocol itself will need to use NextHopFaceId field
  3. laptop's RIB daemon collects routable prefixes from all connected gateway routers (ndn:/localhop/spurs/nfd/rib/routable-prefixes + ndn:/localhop/hobo/nfd/rib/routable-prefixes + ...)
  4. apps learn routable prefixes from laptop's RIB daemon at ndn:/localhost/nfd/rib/routable-prefixes as a StatusDataset

#5 Updated by Junxiao Shi over 4 years ago

  • Blocks Feature #2512: ndn-autoconf-server: publish routable-prefixes as a StatusDataset added

#6 Updated by Junxiao Shi over 4 years ago

  • Status changed from New to In Progress

For now I'll describe the protocol in local-prefix-discovery.rst without mentioning StatusDataset.

Eventually the protocol will be part of Management.

#7 Updated by Junxiao Shi over 4 years ago

  • Status changed from In Progress to Code review
  • % Done changed from 0 to 100

#8 Updated by Junxiao Shi over 4 years ago

http://gerrit.named-data.net/1768

One small difference caused by not referencing StatusDataset is: each segment must contain complete Names; a Name cannot be split across two segments.
I don't think this is a big problem for now.

#9 Updated by Junxiao Shi over 4 years ago

  • Status changed from Code review to Resolved

Documentation update is complete, but reviewer suggests that #2512 should merge before this issue's Change.

#10 Updated by Junxiao Shi over 4 years ago

  • Status changed from Resolved to Closed

#11 Updated by Junxiao Shi about 4 years ago

  • Related to Feature #3145: Collect and publish routable-prefixes added

#12 Updated by Junxiao Shi about 4 years ago

The "eventual solution" in note-4 is written as #3142 #3145.

Also available in: Atom PDF