Project

General

Profile

Bug #2792

Incorrect library install path on Ubuntu 32-bit (and some other 32-bit platforms)

Added by Alex Afanasyev over 4 years ago. Updated over 4 years ago.

Status:
Closed
Priority:
High
Category:
Build
Target version:
Start date:
05/06/2015
Due date:
% Done:

100%

Estimated time:

Description

This is caused by incorrect logic in waf script (waf/Utils.py),
and has been addressed by the upstream waf.

We need to track update of waf for maintained projects:

  • ndn-cxx
  • NFD
  • NLSR
  • ndn-tools
  • ndns

Related issues

Related to NFD - Bug #2711: Incorrect built-in `PKG_CONFIG_PATH` on Ubuntu 32-bit platformClosed2015-03-30

History

#1 Updated by Alex Afanasyev over 4 years ago

  • Description updated (diff)

#2 Updated by Junxiao Shi over 4 years ago

  • Description updated (diff)
  • Priority changed from Normal to High

#3 Updated by Junxiao Shi over 4 years ago

  • Related to Bug #2711: Incorrect built-in `PKG_CONFIG_PATH` on Ubuntu 32-bit platform added

#4 Updated by Alex Afanasyev over 4 years ago

  • Status changed from In Progress to Code review

#5 Updated by Alex Afanasyev over 4 years ago

  • % Done changed from 0 to 100

#6 Updated by Davide Pesavento over 4 years ago

Is this the fix -> https://github.com/waf-project/waf/commit/47cf5cecaa4f1be287cf3be70e57f764e02935f2 ?
If so, the logic is still not correct on Gentoo (but it'll work anyway because /usr/lib is a symlink to /usr/lib64)

#7 Updated by Alex Afanasyev over 4 years ago

Yes. This is the fix..

I'm not really sure why there is a check for non-existence of /usr/lib32. I guess the guys had some reason for that. Does gentoo has both /usr/lib32 and /usr/lib64?

#8 Updated by Davide Pesavento over 4 years ago

Yes, gentoo has both. Moreover, /usr/lib points to /usr/lib64, but the latter is the preferred/canonical install path for 64-bit software.

#9 Updated by Junxiao Shi over 4 years ago

  • Status changed from Code review to Closed

Also available in: Atom PDF