Project

General

Profile

Task #4672

ndnSIM Congestion Control: Implement BIC and CUBIC

Added by Klaus Schneider 9 months ago. Updated about 1 month ago.

Status:
Closed
Priority:
Normal
Category:
-
Target version:
-
Start date:
07/18/2018
Due date:
% Done:

100%

Estimated time:

Description

In addition to task #4578, we want to implement the BIC and CUBIC window adaptation.

An early version of the code is available in this Hackathon repository: https://github.com/6th-ndn-hackathon/congestion-control

More specifically:


Related issues

Related to ndnSIM - Feature #4578: Make NFD Congestion Control work in ndnSIMClosed

History

#1 Updated by Klaus Schneider 9 months ago

  • Related to Feature #4578: Make NFD Congestion Control work in ndnSIM added

#2 Updated by Klaus Schneider 9 months ago

Actually the current code also has a bug that results in a runtime error:

terminate called after throwing an instance of 'boost::exception_detail::clone_imp
lboost::exception_detail::error_info_injector<ndn::name::Component::Error >'
what(): Name component does not have the requested marker or the value is not a
nonNegativeInteger

It's caused by the line

uint64_t sequenceNum = data->getName().get(-1).toSegment();

which should read

uint64_t sequenceNum = data->getName().get(-1).toSequenceNumber();

#3 Updated by Klaus Schneider 9 months ago

  • Status changed from New to Code review

#5 Updated by Klaus Schneider about 1 month ago

  • Status changed from Code review to Closed
  • % Done changed from 0 to 100

Done a long time ago.

Also available in: Atom PDF