Project

General

Profile

Feature #1996

LocalControlHeader: caching

Added by Junxiao Shi about 7 years ago. Updated about 7 years ago.

Status:
Closed
Priority:
Normal
Assignee:
Category:
Protocol
Target version:
Start date:
Due date:
% Done:

100%

Estimated time:
1.50 h

Description

In LocalControlHeader, add a Caching feature.

Application MAY attach a Caching field on a Data packet to NFD, to give ContentStore an instruction about whether/how to cache the Data packet.

Initially, we only define one possible instruction:

  • NoCache: ContentStore SHOULD NOT cache the Data packet.

Caching field MUST NOT be attached to a packet from NFD to application, or to a non-Data packet.


Related issues

Related to ndn-cxx - Task #1940: In Memory StorageClosedJiewen Tan

Actions
#1

Updated by Junxiao Shi about 7 years ago

#2

Updated by Junxiao Shi about 7 years ago

The necessity of this feature is suggested by InMemoryStorage:

Since an application has already kept a copy of data packet, it should be able to inform the local daemon not to keep a copy in the content store.

Jiewen Tan, who's working on in-memory storage, has confirmed that the idea in Task Description satisfies the need from in-memory storage:

I just want to say I think the idea you provide is a good idea.

#3

Updated by Junxiao Shi about 7 years ago

  • Status changed from New to In Progress
#4

Updated by Junxiao Shi about 7 years ago

  • Status changed from In Progress to Resolved
  • % Done changed from 0 to 100

LocalControlHeader rev25 and FaceMgmt rev43 are updated, please review.

#5

Updated by Junxiao Shi about 7 years ago

  • Status changed from Resolved to Closed

20141024 conference call approves this protocol design.

Before this can be implemented, we'll need fine-grained privilege control in NFD Management, because:

  • Usage of CachingPolicy needs faces/enable-local-control command.
  • Most applications should be allowed to use CachingPolicy.
  • Only few applications should be allowed to use other local control features.

Also available in: Atom PDF