Project

General

Profile

Bug #3059

ndn-net-device-face.t.cpp unit test occasionally fails.

Added by Spyros Mastorakis over 3 years ago. Updated over 3 years ago.

Status:
Closed
Priority:
Normal
Category:
tests
Target version:
Start date:
07/18/2015
Due date:
% Done:

100%

Estimated time:

Description

Sometimes the output of faceStatus.getNInInterests() (line 80) is 2000 and others 1999. That is why sometimes the unit test fails.

History

#1 Updated by Spyros Mastorakis over 3 years ago

  • Category set to tests
  • Status changed from New to Code review
  • Assignee set to Spyros Mastorakis
  • Target version set to 2.1
  • % Done changed from 0 to 90

#2 Updated by Junxiao Shi over 3 years ago

What's the root cause of faceStatus.getNInInterests() off-by-one? What's that extra incoming Interest?

It's not right to simply accept both possibilities without finding the root cause.

#3 Updated by Spyros Mastorakis over 3 years ago

The root cause is that the ndnSIM test cases are actual simulation scenarios. For this one, if you modify the stop time of the simulation from 20 sec to 20.00001 sec, then the test case does not fail.

#4 Updated by Spyros Mastorakis over 3 years ago

  • Status changed from Code review to Closed
  • % Done changed from 90 to 100

Also available in: Atom PDF