Project

General

Profile

Task #3894

Remove use of NDNS_CERT_QUERY ("KEY") that is used to serve KEY requests

Added by Alex Afanasyev over 3 years ago. Updated over 2 years ago.

Status:
Closed
Priority:
Normal
Assignee:
-
Target version:
-
Start date:
12/18/2016
Due date:
% Done:

0%

Estimated time:

Description

A dedicated "KEY" component is currently used to serve certificate requests, instead of "NDNS" (i.e., to match name of actual certificate and store it as is as NDNS record).

We will need to remove this, as certificates will be stored in encapsulated form.

#1

Updated by Yumin Xia over 3 years ago

So the issue is to:

  1. use "NDNS" instead of "KEY";
  2. store certificates in encapsulated form.

right?

#2

Updated by Alex Afanasyev over 3 years ago

Almost. All non-NDNS certificate should be stored in encapsulated form. For NDNS-specific certs, I was thinking to have a hack to store them as is (kind of weird to encapsulate them). The latter needs additional logic in the keychain that doesn't yet exist.

#3

Updated by Yumin Xia over 3 years ago

Hi @Alex,

Could you elaborate more on this issue?

#4

Updated by Yumin Xia over 2 years ago

  • Status changed from New to Closed

Also available in: Atom PDF