Project

General

Profile

Bug #4745

ndncatchunks terminates without receiving every data chunk

Added by Ryan Wickman about 2 years ago. Updated almost 2 years ago.

Status:
Closed
Priority:
Normal
Assignee:
Start date:
Due date:
% Done:

100%

Estimated time:

Description

This occurs when it will erroneously recount a duplicated chuck. Thus the count will be off and the number of not received chunks is proportional to the number of duplicates recounted.
I wrote a script that will automatically check for this pattern:

Segment #1097 was erroneously retransmitted after it was received!
Segment #1096 was erroneously retransmitted after it was received!
Segment #1095 was erroneously retransmitted after it was received!
Segment #2325 was never received!
Segment #2326 was never received!
Segment #2327 was never received!
Only 2325 out of 2328 segments were received!

As you can see, three segments were recounted causing three segments to never be received.


Related issues

Is duplicate of ndn-tools - Bug #4604: ndncatchunks: impossible computed RTT valuesClosedRyan Wickman

Actions
#1

Updated by Ryan Wickman about 2 years ago

I already fixed this issue, but I fixed it as part of #3902, which still needs to get fixed. So I decided to make this it owns separate ticket since it is a pretty serious issue.

I removed m_nReceived and create std::set m_receivedSet in its place.

#2

Updated by Davide Pesavento about 2 years ago

  • Assignee set to Ryan Wickman
  • Start date deleted (09/26/2018)

Ryan Wickman wrote:

I already fixed this issue, but I fixed it as part of #3902, which still needs to get fixed. So I decided to make this it owns separate ticket since it is a pretty serious issue.

Yeah I remember. It is indeed pretty serious. Can you submit a patch that addresses just this bug, since it doesn't look like we have a clear solution for #3902 yet?

#3

Updated by Ryan Wickman about 2 years ago

Yes I will once I finish decoupling it from the other fix.

#4

Updated by Davide Pesavento almost 2 years ago

  • Status changed from New to Code review
  • % Done changed from 0 to 100
#5

Updated by Davide Pesavento almost 2 years ago

  • Status changed from Code review to Closed

This has been fixed in commit 2c9933c94f04eddba532e68f2be38d14b0a5621e (bug #4604) since the underlying cause was the same for both bugs.

#6

Updated by Davide Pesavento almost 2 years ago

  • Is duplicate of Bug #4604: ndncatchunks: impossible computed RTT values added

Also available in: Atom PDF