Project

General

Profile

Feature #4913

Update Interest::matchesData for v0.3 semantics

Added by Junxiao Shi 9 months ago. Updated 8 months ago.

Status:
Closed
Priority:
Normal
Assignee:
Category:
Base
Target version:
Start date:
Due date:
% Done:

100%

Estimated time:
3.00 h

Description

Stop processing Selectors in Interest::matchesData.

Deprecate ill-designed and unused Interest::matchesName function.

History

#1

Updated by Junxiao Shi 9 months ago

  • Status changed from New to In Progress
  • Assignee set to Junxiao Shi
#2

Updated by Junxiao Shi 9 months ago

  • % Done changed from 0 to 10

https://gerrit.named-data.net/5445 patchset1 is the basic change.
I anticipate broken test cases in ndn-cxx and other projects.

#3

Updated by Junxiao Shi 8 months ago

  • % Done changed from 10 to 70

https://gerrit.named-data.net/5445 patchset2 fixes ndn-cxx tests.
I have confirmed NFD, ChronoSync, PSync, and repo-ng tests are unaffected.
https://gerrit.named-data.net/5450 fixes ndn-tools tests.
https://gerrit.named-data.net/5451 fixes NLSR tests.

#4

Updated by Junxiao Shi 8 months ago

In https://gerrit.named-data.net/5445 patchset2, Interest to Interest comparison only considers Name, CanBePrefix, and MustBeFresh.
Regarding other fields:

  • ForwardingHint: should be considered, but there are implications in NFD's PIT structure, so I'm not changing it until #3162.
  • Nonce, InterestLifetime, HopLimit: should not be considered because they do not affect Interest-Data matching and do not create separate PIT entries.
  • ApplicationParameters: should be considered, and it's already covered by comparing Name via the ParametersSha256DigestComponent being implemented in #4658.
#5

Updated by Junxiao Shi 8 months ago

  • Status changed from In Progress to Code review
  • % Done changed from 70 to 100

I have confirmed NFD tests are unaffected.

Oh well, I forgot unit-tests-tools. It's fixed in https://gerrit.named-data.net/5452

#6

Updated by Junxiao Shi 8 months ago

  • Status changed from Code review to Closed

Also available in: Atom PDF