Project

General

Profile

Task #5087

Updated by Davide Pesavento over 1 year ago

Ubuntu 20.04 will be released on April 23, 2020. Per platform policy, that means we can drop support for 16.04 and raise our minimum requirement to 18.04. Similarly, we should also drop CentOS 7 support and require CentOS 8 or later. 
 As a consequence, we can raise the minimum version of toolchain components and various other dependencies. I suggest the following: 

 * gcc >= 7 
 * clang >= 5 
 * boost >= 1.65.1 1.65 
 * openssl >= 1.1.1 

 Potentially, we could also switch the codebase to C++17, but I'll consider that separately at a later time.

Back