Project

General

Profile

Bug #1668

udp4 multicast disappears when attempted to be used

Added by Alex Afanasyev over 5 years ago. Updated about 5 years ago.

Status:
Closed
Priority:
High
Category:
Faces
Target version:
Start date:
06/15/2014
Due date:
% Done:

100%

Estimated time:

Description

Environment: OSX 10.9

Steps to reproduce:

  1. Register some prefix for udp4 multicast face:

    [cawka@cawka-mac NFD (master)]$ nfd-status -f
    Faces:
      faceid=1 remote=internal:// local=internal:// counters={in={0i 29d} out={19i 0d}}
      faceid=2 remote=udp4://224.0.23.170:56363 local=udp4://10.0.0.2:56363 counters={in={0i 0d} out={0i 0d}}
      faceid=3 remote=udp4://224.0.23.170:56363 local=udp4://127.0.0.1:56363 counters={in={0i 0d} out={0i 0d}}
      faceid=4 remote=ether://[01:00:5e:00:17:aa] local=dev://bridge0 counters={in={0i 0d} out={0i 0d}}
      faceid=5 remote=ether://[01:00:5e:00:17:aa] local=dev://en0 counters={in={0i 0d} out={0i 0d}}
      faceid=6 remote=ether://[01:00:5e:00:17:aa] local=dev://en1 counters={in={0i 0d} out={0i 0d}}
    
    [cawka@cawka-mac NFD (master)]$ nfdc register /localhop 2
    Successful in name registration: ControlParameters(Name: /localhop, FaceId: 2, Origin: 0, Cost: 0, Flags: 1, ExpirationPeriod: 3600000 milliseconds, )
    
  2. Try to fetch some data from the registered prefix

    [cawka@cawka-mac NFD (master)]$ ndn-tlv-peek /localhop/test
    

Expected: no data fetched and no changes in face list

Actual: no data fetched, but UDP4 multicast face disappears:

[cawka@cawka-mac NFD (master)]$ nfd-status -f
Faces:
  faceid=1 remote=internal:// local=internal:// counters={in={0i 35d} out={26i 0d}}
  faceid=3 remote=udp4://224.0.23.170:56363 local=udp4://127.0.0.1:56363 counters={in={0i 0d} out={0i 0d}}
  faceid=4 remote=ether://[01:00:5e:00:17:aa] local=dev://bridge0 counters={in={0i 0d} out={0i 0d}}
  faceid=5 remote=ether://[01:00:5e:00:17:aa] local=dev://en0 counters={in={0i 0d} out={0i 0d}}
  faceid=6 remote=ether://[01:00:5e:00:17:aa] local=dev://en1 counters={in={0i 0d} out={0i 0d}}

The following is in NFD's log:

1402873627.437623 INFO: [FaceTable] Removed face id=2 remote=udp4://224.0.23.170:56363 local=udp4://10.0.0.2:56363

History

#1 Updated by Junxiao Shi over 5 years ago

  • Description updated (diff)

I suspect UdpMulticastFace is set to close itself when an error condition is detected, instead of ignoring the error.

#2 Updated by Junxiao Shi over 5 years ago

  • Tracker changed from Task to Bug

I cannot reproduce this bug on Ubuntu 12.04.
If this bug is specific to a platform, update Description to include that information.

#3 Updated by Alex Afanasyev about 5 years ago

Could be OSX specific problem. More detailed logging revealed the following error:

1403130228.401727 WARNING: [MulticastUdpFace] [id:2,endpoint:224.0.23.170:56363] Send operation failed, closing socket: Can't assign requested address

#4 Updated by Junxiao Shi about 5 years ago

  • Description updated (diff)
  • Assignee set to Giulio Grassi

Confirmed on OSX 10.9.

#5 Updated by Alex Afanasyev about 5 years ago

  • Status changed from New to In Progress
  • Assignee changed from Giulio Grassi to Alex Afanasyev
  • % Done changed from 0 to 30

#6 Updated by Alex Afanasyev about 5 years ago

  • % Done changed from 30 to 90

#7 Updated by Alex Afanasyev about 5 years ago

  • Status changed from In Progress to Code review

#8 Updated by Alex Afanasyev about 5 years ago

  • % Done changed from 90 to 100

#9 Updated by Alex Afanasyev about 5 years ago

  • Status changed from Code review to Closed

Also available in: Atom PDF