Project

General

Profile

Task #1810

ERROR: command response timeout from "ndnputfile"

Added by Ali Khan over 4 years ago. Updated almost 2 years ago.

Status:
Closed
Priority:
Normal
Assignee:
-
Target version:
-
Start date:
07/29/2014
Due date:
% Done:

100%

Estimated time:

Description

I have tried to put a test file to the repo by using command "ndnputfile ndn:/example/repo ndn:/example/hello.txt ./hello.txt". However, I have received an error message about "command response timeout".

I found that the ndnput file try to create a Face, but the connection was closed and removed immediately.

######################### Here is INFO messages that I got:

interlab@12:~/repo-ng$ ndn-repo-ng

1406692411.529349 INFO: [FaceTable] Added face id=4 remote=fd://16 local=unix:///run/nfd.sock

1406692433.191490 INFO: [FaceTable] Added face id=5 remote=fd://17 local=unix:///run/nfd.sock

1406692433.329152 INFO: [UnixStreamFace] [id:5,endpoint:/run/nfd.sock] Connection closed

1406692433.351592 INFO: [FaceTable] Removed face id=5 remote=fd://17 local=unix:///run/nfd.sock

######################### In addition, I also attached the nfd-status for your further investigation.

General NFD status:

           version=2000

         startTime=20140730T035321.367000

       currentTime=20140730T045907.631000

            uptime=3946 seconds

  nNameTreeEntries=25

       nFibEntries=10

       nPitEntries=2

nMeasurementsEntries=0

        nCsEntries=40

      nInInterests=105

     nOutInterests=102

          nInDatas=40

         nOutDatas=38

Channels:

ws://0.0.0.0:9696

unix:///run/nfd.sock

udp4://0.0.0.0:6363

tcp4://0.0.0.0:6363

Faces:

faceid=1 remote=internal:// local=internal:// counters={in={0i 32d} out={95i 0d}} local

faceid=2 remote=udp4://224.0.23.170:56363 local=udp4://192.168.1.223:56363 counters={in={0i 0d} out={0i 0d}}

faceid=3 remote=fd://15 local=unix:///run/nfd.sock counters={in={88i 10d} out={10i 23d}} local on-demand

faceid=4 remote=fd://16 local=unix:///run/nfd.sock counters={in={8i 0d} out={0i 8d}} local on-demand

faceid=8 remote=fd://17 local=unix:///run/nfd.sock counters={in={3i 0d} out={0i 2d}} local on-demand

FIB:

/example/repo/1/delete nexthops={faceid=4 (cost=0)}

/example/data/2 nexthops={faceid=4 (cost=0)}

/example/repo/1/insert nexthops={faceid=4 (cost=0)}

/localhost/nfd nexthops={faceid=1 (cost=0)}

/example/repo/2/insert%20check nexthops={faceid=4 (cost=0)}

/example/repo/2/insert nexthops={faceid=4 (cost=0)}

/example/data/1 nexthops={faceid=4 (cost=0)}

/example/repo/1/insert%20check nexthops={faceid=4 (cost=0)}

/example/repo/2/delete nexthops={faceid=4 (cost=0)}

/localhost/nfd/rib nexthops={faceid=3 (cost=0)}

Strategy choices:

/ strategy=/localhost/nfd/strategy/best-route


Related issues

Is duplicate of repo-ng - Task #1887: The problem of ndnputfile and ndngetfileClosed2014-08-18

History

#1 Updated by Ali Khan over 4 years ago

I am a newbie of NDN platform and so sorry, if my proposed issue was not clear. Actually, I would like to use ndnputfile tool to send some files to repo server. Therefore, I would kindly ask that are there some prior steps to run the ndnputfile.

Currently, what I have done is :

1 run nfd-start

2 run ndn-repo-ng -->As a result, the repo and ndn prefixes declared in configuration file were shown on FIB table.

3 run "ndnputfile ndn:/example/repo ndn:/example/hello.txt ./hello.txt"
--> As a result, I got an ERROR: check response timeout. I found that the process was stop in function
"onCheckCommandTimeout".

Thank you very much.

#2 Updated by Weiqi Shi over 4 years ago

Sorry for the delay of reply. It seems you did not run nrd after running the nfd? Both repo and ndnputfile should work correctly after you start running nrd. Hope this can help you.

#3 Updated by Ali Khan over 4 years ago

Thank you WeiqiShi for your response. Actually, nrd were run already after running the nfd, but repo and ndnputfile still did not work correctly.

Here below is the process running on my pc.

root      3506  3504  1 21:45 pts/0    00:00:01 nfd
interlab  3507  1150  0 21:45 pts/0    00:00:00 nrd
interlab  3521  2302  1 21:46 pts/24   00:00:00 bash
interlab  3579  3186  6 21:46 pts/23   00:00:00 ndnputfile ndn:/example/repo ndn:/example/files/hello.txt ./hello.txt
interlab  3580  3521  0 21:46 pts/24   00:00:00 ps -ef

After running ndnputfile, I got an error ERROR: check response timeout and ndn-repo-ng was also quit unexpectedly.

Thank you again for your help.

#4 Updated by Shuo Chen over 4 years ago

Can you use -v (verbose) option to show the log?

#5 Updated by Ali Khan over 4 years ago

Here is the log from ndnputfile with -v option.

interlab@12:~/repo-ng$ ndnputfile -v ndn:/example/repo ndn:/example/files/hello.txt ./hello.txt

setInterestFilter for /example/files/hello.txt/%00%00%01G%D2%5C%C0R

Requested segment [1] does not exist

Requested segment [2] does not exist

Requested segment [3] does not exist

Requested segment [4] does not exist

Requested segment [5] does not exist

Requested segment [6] does not exist

Requested segment [7] does not exist

Requested segment [8] does not exist

Requested segment [9] does not exist

Requested segment [10] does not exist

Requested segment [11] does not exist

ERROR: check response timeout

interlab@12:~/repo-ng$

-------------------- And here is the log from ndn-repo-ng --------------------

interlab@12:~$ ndn-repo-ng

1407983542.223688 INFO: [FaceTable] Added face id=265 remote=fd://15
local=unix:///run/nfd.sock

1407983576.308190 INFO: [FaceTable] Added face id=266 remote=fd://16 local=unix:///run/nfd.sock

1407983576.487471 INFO: [UnixStreamFace] [id:266,uri:fd://16] Connection closed

1407983576.510065 INFO: [FaceTable] Removed face id=266 remote=fd://16 local=unix:///run/nfd.sock

1407983585.763372 INFO: [FaceTable] Added face id=267 remote=fd://16 local=unix:///run/nfd.sock

1407983585.922342 INFO: [UnixStreamFace] [id:267,uri:fd://16] Connection closed

1407983585.948934 INFO: [FaceTable] Removed face id=267 remote=fd://16 local=unix:///run/nfd.sock

1407983599.726485 INFO: [FaceTable] Added face id=268 remote=fd://16 local=unix:///run/nfd.sock

insert sql not prepared

ERROR: Some error with insert

1407983599.885067 INFO: [UnixStreamFace] [id:265,uri:fd://15] Connection closed

interlab@12:~$ 1407983599.907592 INFO: [FaceTable] Removed face id=265 remote=fd://15 local=unix:///run/nfd.sock

1407983604.892026 INFO: [UnixStreamFace] [id:268,uri:fd://16] Connection closed

1407983604.912764 INFO: [FaceTable] Removed face id=268 remote=fd://16 local=unix:///run/nfd.sock

Thank you!

#6 Updated by Ali Khan over 4 years ago

I also try to use a large file and here below is the log from ndnputfile with verbose option

setInterestFilter for /example/files/image.JPG/%00%00%01G%D2q3%17

ERROR: check response timeout

------------------ And here is the log from ndn-repo-ng ------------------------------

interlab@12:~$ ndn-repo-ng

1407992340.647707 INFO: [FaceTable] Added face id=277 remote=fd://15 local=unix:///run/nfd.sock

1407992359.343521 INFO: [FaceTable] Added face id=278 remote=fd://16 local=unix:///run/nfd.sock

insert sql not prepared

ERROR: 1407992359.683003 INFO: [UnixStreamFace] [id:277,uri:fd://15] Connection closed

Some error with insert

interlab@12:~$ 1407992359.706542 INFO: [FaceTable] Removed face id=277 remote=fd://15 local=unix:///run/nfd.sock

1407992359.728234 WARNING: [Forwarder] onOutgoingData face=invalid data=/example/files/image.JPG/%00%00%01G%D2%E2i%93/%01

1407992359.934129 WARNING: [Forwarder] onOutgoingData face=invalid data=/example/files/image.JPG/%00%00%01G%D2%E2i%93/%02

1407992359.935248 WARNING: [Forwarder] onOutgoingData face=invalid data=/example/files/image.JPG/%00%00%01G%D2%E2i%93/%03

1407992359.936032 WARNING: [Forwarder] onOutgoingData face=invalid data=/example/files/image.JPG/%00%00%01G%D2%E2i%93/%04

1407992359.936834 WARNING: [Forwarder] onOutgoingData face=invalid data=/example/files/image.JPG/%00%00%01G%D2%E2i%93/%05

1407992359.937592 WARNING: [Forwarder] onOutgoingData face=invalid data=/example/files/image.JPG/%00%00%01G%D2%E2i%93/%06

1407992359.938351 WARNING: [Forwarder] onOutgoingData face=invalid data=/example/files/image.JPG/%00%00%01G%D2%E2i%93/%07

1407992359.939244 WARNING: [Forwarder] onOutgoingData face=invalid data=/example/files/image.JPG/%00%00%01G%D2%E2i%93/%08

1407992359.940001 WARNING: [Forwarder] onOutgoingData face=invalid data=/example/files/image.JPG/%00%00%01G%D2%E2i%93/%09

1407992359.940806 WARNING: [Forwarder] onOutgoingData face=invalid data=/example/files/image.JPG/%00%00%01G%D2%E2i%93/%0A

1407992359.941584 WARNING: [Forwarder] onOutgoingData face=invalid data=/example/files/image.JPG/%00%00%01G%D2%E2i%93/%0B

1407992364.509554 INFO: [UnixStreamFace] [id:278,uri:fd://16] Connection closed

1407992364.530603 INFO: [FaceTable] Removed face id=278 remote=fd://16 local=unix:///run/nfd.sock

Thank you

#7 Updated by Weiqi Shi over 4 years ago

I am not very sure about this, but I think if you may want to insert a single data, you need to specify -s,
Besides, the default repo prefix registered is /example/repo/1, so if you would use "ndnputfile -s ndn:/example/repo/1 ndn:/example/hello.txt hello.txt", it could work.

#8 Updated by Weiqi Shi over 4 years ago

This issue will be solved in the task# 1887.

#9 Updated by Weiqi Shi over 4 years ago

  • Status changed from New to Resolved
  • % Done changed from 0 to 100

#10 Updated by Junxiao Shi almost 2 years ago

  • Is duplicate of Task #1887: The problem of ndnputfile and ndngetfile added

#11 Updated by Junxiao Shi almost 2 years ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF