Project

General

Profile

Task #1901

Strategy for backbone router

Added by Junxiao Shi almost 6 years ago. Updated about 3 years ago.

Status:
Duplicate
Priority:
High
Assignee:
Category:
Forwarding
Target version:
-
Start date:
Due date:
% Done:

0%

Estimated time:
18.00 h

Description

Develop a strategy suitable for remote prefixes on backbone router.

This strategy should have the following features:

  • Make use of multiple paths in FIB entry, and learn the best path.
    • In the normal case, it's expected that all paths can reach the destination.
  • Recovery from packet loss in wide-area tunnels.
    • Consumer retransmission is a hint for strategy to retransmit.

Related issues

Is duplicate of NFD - Feature #3566: Adaptive Forwarding Strategy for hyperbolic routingClosedVince Lehman

Actions
#1

Updated by Junxiao Shi almost 6 years ago

  • Subject changed from Strategy for testbed router to Strategy for backbone router
  • Description updated (diff)
  • Priority changed from Normal to High
#2

Updated by Junxiao Shi almost 6 years ago

  • Target version deleted (v0.3)

I feel that a backbone router strategy needs congestion control, which depends on NACK.

Therefore I can't design this strategy before we have NACK in NDN-TLV.

#3

Updated by Junxiao Shi about 3 years ago

  • Is duplicate of Feature #3566: Adaptive Forwarding Strategy for hyperbolic routing added
#4

Updated by Junxiao Shi about 3 years ago

  • Status changed from New to Duplicate

Backbone is now using hyperbolic routing and ASF forwarding strategy. No separate backbone strategy is needed.

Also available in: Atom PDF