Project

General

Profile

Bug #2204

Cannot create local UDP Face

Added by Adeola Bannis about 6 years ago. Updated about 6 years ago.

Status:
Rejected
Priority:
Normal
Assignee:
-
Category:
Faces
Target version:
-
Start date:
11/20/2014
Due date:
% Done:

0%

Estimated time:

Description

In TcpChannel, the endpoint of the face is checked for localhost scope (https://github.com/named-data/NFD/blob/master/daemon/face/tcp-channel.cpp#L138), but in UdpChannel, there is no such check, and so it is not possible to make a local UDP face. As a result, applications trying to register prefixes with a UDP face are rejected for violating localhost scope.

#1

Updated by Junxiao Shi about 6 years ago

  • Tracker changed from Task to Bug
  • Status changed from New to Rejected

This behavior is by design.

Applications should use UNIX stream socket or TCP socket or WebSockets to talk to local forwarder.
The preference among these is UNIX > TCP > WebSockets.

I'm not aware of any library / framework that supports none of them or incur a major performance penalty.
If there is, please point out, and attach performance benchmark that shows UNIX/TCP socket is a bottleneck.

UDP faces are only used between forwarders.
Application shouldn't connect on UDP sockets.

Also available in: Atom PDF