Project

General

Profile

Task #2347

Investigate why gcc46 segfaults when NameTree::const_iterator inherited from std::iterator<std::forward_iterator_tag, const name::Entry>

Added by Alex Afanasyev almost 7 years ago. Updated almost 7 years ago.

Status:
Closed
Priority:
Normal
Category:
Build
Target version:
Start date:
01/05/2015
Due date:
% Done:

100%

Estimated time:

Description

for not yet known reason, gcc4.6 on Ubuntu 12.04 segfaults when NameTree::const_iterator inherited from std::iterator<std::forward_iterator_tag, const name::Entry>:

[133/173] Compiling tests/daemon/mgmt/face-manager.cpp
../tests/daemon/mgmt/face-manager.cpp: In member function ‘void nfd::tests::MgmtFaceManager::LocalControlNextHopFaceIdNonLocal::test_method()’:
../tests/daemon/mgmt/face-manager.cpp:1859:1: internal compiler error: Segmentation fault
Please submit a full bug report,
with preprocessed source if appropriate.
See <file:///usr/share/doc/gcc-4.6/README.Bugs> for instructions.
Preprocessed source stored into /tmp/ccseBdu8.out file, please attach this to your bugreport.

Files

ccseBdu8.out.gz (633 KB) ccseBdu8.out.gz Preprocessed source Alex Afanasyev, 01/05/2015 02:11 PM
#1

Updated by Junxiao Shi almost 7 years ago

  • Description updated (diff)
  • Category set to Build
  • Target version set to v0.3

Please attach the preprocessed source.

#2

Updated by Alex Afanasyev almost 7 years ago

#3

Updated by Junxiao Shi almost 7 years ago

  • Subject changed from Investigate why gcc46 segfaults when NameTree::const_iterator inherited from std::iterator(std::forward_iterator_tag, const name::Entry) to Investigate why gcc46 segfaults when NameTree::const_iterator inherited from std::iterator<std::forward_iterator_tag, const name::Entry>
  • Description updated (diff)
  • Category set to Build
  • Target version set to v0.3

Also, post the command line that invokes the compiler.

#4

Updated by Alex Afanasyev almost 7 years ago

It's inside .out file

#5

Updated by Junxiao Shi almost 7 years ago

I'm able to reproduce the error with commit 74d540bbb5490e394da75eb9bff84d455f7e41fa, however ccseBdu8.out compiles fine in my environment.

I have confirmed that this is not an out-of-memory condition, because the same error occurs when the box is allocated 32GB memory.

#6

Updated by Alex Afanasyev almost 7 years ago

Code seem to compile if I remove -g flag

#7

Updated by Alex Afanasyev almost 7 years ago

  • Status changed from New to Code review
  • Assignee set to Alex Afanasyev
  • % Done changed from 0 to 50
#8

Updated by Junxiao Shi almost 7 years ago

What else is left in this Task?

#9

Updated by Alex Afanasyev almost 7 years ago

We can close. There is nothing else to do. However, we never actually figure out what is the problem, just avoided it.

#10

Updated by Junxiao Shi almost 7 years ago

  • Status changed from Code review to Closed
  • % Done changed from 50 to 100

Also available in: Atom PDF