Project

General

Profile

Bug #2467

HUB discovery scenario: does not terminate after 30 minutes

Added by Junxiao Shi over 6 years ago. Updated over 6 years ago.

Status:
Closed
Priority:
Normal
Assignee:
-
Category:
Integration Tests
Target version:
Start date:
02/02/2015
Due date:
% Done:

0%

Estimated time:

Description

HUB discovery scenario fails to terminate after 30 minutes.

The problem is in test-B-stage1.sh where ndn-autoconfig does not terminate.

It is probably caused by a Bug in ndn-autoconfig.

integ: d5033e909b9b79b30cfc40dfe98a7ba70118dd87

ndn-cxx: cf3a667634ef93c47c0ef3056a01c47112e49427

NFD: e46279dc8382316fb933697346b66f22cad1ee5e


Files

integ20150201.tar (81.5 KB) integ20150201.tar Junxiao Shi, 02/02/2015 07:13 AM

Related issues

Related to NFD - Task #2469: ndn-autoconfig doesn't terminate in single-shot modeClosedAlex Afanasyev02/02/2015

Actions
#1

Updated by Junxiao Shi over 6 years ago

After manually killing ndn-autoconfig process, the same problem occurs in stage2 and stage3 scripts as well (although I only waited for about one minute each).

Test logs are attached.

#2

Updated by Alex Afanasyev over 6 years ago

  • Is duplicate of Bug #2459: ndn-autoconfig (daemon mode): non-deterministic timeouts for DNS resolution added
#3

Updated by Junxiao Shi over 6 years ago

This shouldn't be caused by #2459.
In this integration scenario, bind9 is running on host A, and /etc/resolv.conf either points to Emulab NS server or host A.

#4

Updated by Alex Afanasyev over 6 years ago

The only place stage2/3 can hang is in DNS resolution (res_query and res_search), so it is somehow caused by #2459

#5

Updated by Junxiao Shi over 6 years ago

  • Description updated (diff)

This scenario was working a few weeks ago. res_query and res_search were used in the same way back then.

All three stages have the same problem: test-B-stage1.sh test-D-stage2.sh test-D-stage3.sh.

(test-B-stage2.sh was a typo. There's no such file. It's corrected now)

#6

Updated by Alex Afanasyev over 6 years ago

  • Is duplicate of deleted (Bug #2459: ndn-autoconfig (daemon mode): non-deterministic timeouts for DNS resolution)
#7

Updated by Alex Afanasyev over 6 years ago

  • Related to Task #2469: ndn-autoconfig doesn't terminate in single-shot mode added
#8

Updated by Junxiao Shi over 6 years ago

  • Status changed from New to Closed

This problem is caused by #2469. It's fixed as of 20150209.

Also available in: Atom PDF