Project

General

Profile

Bug #2471

binaries: NFD service fails to start

Added by Junxiao Shi over 6 years ago. Updated over 6 years ago.

Status:
Closed
Priority:
Normal
Category:
Build
Target version:
Start date:
02/03/2015
Due date:
% Done:

100%

Estimated time:

Description

Environment: Linux Mint 17

After upgrading nfd package from 0.3.0~rc0.3-ppa2~trusty to 0.3.0-ppa1~trusty,
sudo service nfd restart reports successful, but NFD quits shortly after.

sunny@sunnyq ~ $ tail -5 /var/log/ndn/nfd.log
1422984104.179211 INFO: [FaceTable] Added face id=255 remote=null:// local=null://
1422984104.195068 INFO: [FaceTable] Added face id=254 remote=contentstore:// local=contentstore://
1422984104.211850 INFO: [PrivilegeHelper] dropped to effective uid=115 gid=125
1422984106.204574 INFO: [FaceTable] Added face id=258 remote=fd://18 local=unix:///run/nfd.sock
1422984106.206483 FATAL: [NFD] FileStore: error opening file for reading: /var/lib/ndn/nfd/.ndn/ndnsec-tpm-file/VJhCYu1ltoy6hxMBx6lOV%W%IsHe0mFf4MBggvdM2O8=.pri
sunny@sunnyq ~ $ ll /var/lib/ndn/nfd/.ndn
total 36
drwxr-xr-x 3 root root  4096 Feb  3 10:14 .
drwxr-xr-x 3 root root  4096 Jun  2  2014 ..
-rw-r--r-- 1 root root 18432 Feb  3 10:14 ndnsec-public-info.db
drwxr-xr-x 2 root root  4096 Jun  2  2014 ndnsec-tpm-file
sunny@sunnyq ~ $ ll /var/lib/ndn/nfd/.ndn/ndnsec-tpm-file/
total 20
drwxr-xr-x 2 root root 4096 Jun  2  2014 .
drwxr-xr-x 3 root root 4096 Feb  3 10:14 ..
-rw-r--r-- 1 root root  124 Jun  2  2014 mapping.txt
-r-------- 1 root root 1643 Jun  2  2014 VJhCYu1ltoy6hxMBx6lOV%W%IsHe0mFf4MBggvdM2O8=.pri
-r--r--r-- 1 root root  398 Jun  2  2014 VJhCYu1ltoy6hxMBx6lOV%W%IsHe0mFf4MBggvdM2O8=.pub
#1

Updated by Junxiao Shi over 6 years ago

This problem is caused by:
The package ships a new nfd.conf which causes NFD to change euid to ndn user, but the KeyChain files installed by previous versions are owned by root.

A workaround is:
sudo chown -R ndn:ndn /var/lib/ndn/nfd/.ndn

The solution should be:
run above chown command in postinst script.

#2

Updated by Alex Afanasyev over 6 years ago

  • Status changed from New to In Progress
  • Assignee set to Alex Afanasyev
#3

Updated by Alex Afanasyev over 6 years ago

  • Status changed from In Progress to Resolved
  • % Done changed from 0 to 100

An updated package should be available in PPA repository in a few minutes.

I made the following update to package scripts: https://github.com/named-data/ppa-packaging/commit/60664e2dd2ef1e0251ac64f3c9c7d4a7f22c1312

#4

Updated by Alex Afanasyev over 6 years ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF