Project

General

Profile

Bug #3019

nfd-status-http-server: erroneous <!DOCTYPE html> display

Added by Junxiao Shi about 5 years ago. Updated almost 5 years ago.

Status:
Closed
Priority:
Normal
Assignee:
Category:
Tools
Target version:
Start date:
07/06/2015
Due date:
% Done:

100%

Estimated time:
1.00 h

Description

Environment: Firefox 38.0 for Ubuntu 12.04

Steps to reproduce:

  1. navigate to NFD status HTML page

Actual: <!DOCTYPE html> text on top-left corner



Expected: no such text


Files

#1

Updated by Joao Pereira almost 5 years ago

I was able to reproduce the error with Firefox 39.

Is this something new? Ins't it possible that this is a new "Feature" of Firefox?

Was the tools output changed?

Instead of trying to to solve this error shouldn't we try to change the output of to HTML instead of XML?

#2

Updated by Junxiao Shi almost 5 years ago

change the output of to HTML instead of XML?

Doing XSLT on server-side is unacceptable.

The output of GET / HTTP/1.0 needs to be machine-readable.
Monitoring scripts depend on that.

#4

Updated by Joao Pereira almost 5 years ago

  • Assignee set to Joao Pereira
#5

Updated by Joao Pereira almost 5 years ago

  • % Done changed from 0 to 100

Correction in the commit:

http://gerrit.named-data.net/2271 nfd-status-http-server: erroneous <!DOCTYPE html> display

#6

Updated by Junxiao Shi almost 5 years ago

commit:4e274ac91520ac4b11afb5e651451f21ff590fa2 differs from suggested solution in note-3: method="html" vs method="xml".

I don't know which one is correct.

In either case, this solution needs to be tested with:

  • Internet Explorer 9
  • Internet Explorer 10
  • Firefox
  • Chrome
  • OS X Safari
  • iPhone browser
  • Android Chrome
#7

Updated by Junxiao Shi almost 5 years ago

  • Status changed from New to Code review
#8

Updated by Joao Pereira almost 5 years ago

Answering to Note-6:

If you use method xml you will get XML output that is not converted into a webpage when you see it in the browser.

The tests will be tricky due to my setup I can only test for IE11, Firefox and Chrome

#9

Updated by Junxiao Shi almost 5 years ago

Reply to note-8:

Can you upload an XML (from any testbed router), along with modified XSLT and other static files, to a public HTTP server?

This would allow others to test with their devices.

#10

Updated by Joao Pereira almost 5 years ago

With my commit the output looks like this:

http://jpereira.co.uk/nfd_test/index.xsl

If I change the "html" to "xml" in the xsl file then I get this output:

http://jpereira.co.uk/nfd_test/index_xml.xsl

Tested with success in:

IE11 - Passed

Firefox 39 - Passed

Chrome - Passed

Android Chrome - Passed

#11

Updated by Alex Afanasyev almost 5 years ago

The first link Works on IOS 8.4.

The second returns just a plain text.

#12

Updated by Junxiao Shi almost 5 years ago

My Windows 7 laptop also has IE11 now. I thought it's IE9.

So, IE9 and IE10 are in the past and we don't need to test them.

I tried http://jpereira.co.uk/nfd_test/index.xsl on:

  • Android 5.1.1 Chrome: PASS
  • Windows 7 IE11: PASS
  • Linux Mint Qiana Firefox: PASS
  • Windows Phone Cyan IE: FAIL (but it never worked)

We still need a test on OS X Safari.

#13

Updated by Joao Pereira almost 5 years ago

I was able to get a Mac and tested it.

Tested the link: http://jpereira.co.uk/nfd_test/index.xsl:

  1. OS X Safari: PASS
  2. OS X Chrome: PASS
#14

Updated by Junxiao Shi almost 5 years ago

  • Status changed from Code review to Closed

Also available in: Atom PDF