Project

General

Profile

Task #4610

Make CentOS 7 an official (CI-tested) platform

Added by susmit shannigrahi about 2 years ago. Updated over 1 year ago.

Status:
Closed
Priority:
Normal
Category:
Build
Target version:
Start date:
Due date:
% Done:

100%

Estimated time:

Description

NDN for high energy particle physics (the SANDIE project) requires CentOS7 binaries for deployment.
The existing infrastructure at CERN/CalTech already uses CentOS7 and there is no plan to move away from it.
Therefore binary releases of NFD/ndn-cxx along with unit/integration testing for these platforms would be useful.

The only problem might be the outdated boost (maybe some other dependencies) shipped with CentOS.


Related issues

Is duplicate of NFD - Task #2166: Jenkins: CentOS 7 slaveClosedMd Ashiqur Rahman

Actions
Blocked by NFD - Bug #3403: PrivilegeHelper unit tests fail on Fedora/CentOS due to missing group "nogroup"ClosedDavide Pesavento

Actions
Blocked by ndn-tools - Bug #4852: dump: build fails on CentOS 7ClosedDavide Pesavento

Actions
#1

Updated by Junxiao Shi about 2 years ago

Docker is an industry standard for deploying software on another platform. Docker supports CentOS7. Ubuntu-based NDN software can be packaged into a Docker container (that internally has a Ubuntu image), and run on CentOS7 host machine. NDN software running within Docker is as fast as running natively, and does not consume more memory or CPU.
Is there any reason your deployment cannot use Docker?

#2

Updated by susmit shannigrahi about 2 years ago

They would like to avoid extra maintainace overhead if possible.
Any reason not to support these platforms?

#3

Updated by Junxiao Shi about 2 years ago

They would like to avoid extra maintainace overhead if possible.

What "extra maintenance overhead" are you talking about? It's industry standard to use Docker. There's nothing more to maintain. Developer provides Docker image. Operations team pulls the Docker image, and don't need to change anything. Moreover, operations team doesn't even need to understand how to setup NFD, because it's packaged in the Docker image.

Any reason not to support these platforms?

As you said, Boost is too old.

#4

Updated by Davide Pesavento about 2 years ago

  • Project changed from ndn-cxx to NFD
  • Subject changed from Make CentOS 7 and Fedora official platforms to Make CentOS 7 (and Fedora?) official platforms
  • Category set to Build
  • Target version set to v0.7
#5

Updated by Davide Pesavento almost 2 years ago

  • Subject changed from Make CentOS 7 (and Fedora?) official platforms to Make CentOS 7 an official (CI-tested) platform
  • Status changed from New to In Progress
  • Assignee set to Md Ashiqur Rahman
  • % Done changed from 0 to 20
#6

Updated by Davide Pesavento almost 2 years ago

  • Blocked by Bug #3403: PrivilegeHelper unit tests fail on Fedora/CentOS due to missing group "nogroup" added
#7

Updated by Davide Pesavento almost 2 years ago

  • Is duplicate of Task #2166: Jenkins: CentOS 7 slave added
#8

Updated by Davide Pesavento over 1 year ago

  • % Done changed from 20 to 60
#9

Updated by Davide Pesavento over 1 year ago

  • Blocked by Bug #4852: dump: build fails on CentOS 7 added
#10

Updated by Davide Pesavento over 1 year ago

  • Status changed from In Progress to Closed
  • % Done changed from 60 to 100

Finally enabled CentOS CI-testing for ndn-tools too (NFD and ndn-cxx were added several months ago)

Also available in: Atom PDF