Project

General

Profile

Bug #4697

Fatal bind error when initializing multicast UDP faces

Added by Alexander Lane almost 2 years ago. Updated over 1 year ago.

Status:
Rejected
Priority:
Normal
Category:
Faces
Target version:
-
Start date:
Due date:
% Done:

0%

Estimated time:

Description

In a Mini-NDN-Wifi environment, we have repeatedly received fatal errors from bind when creating UDP multicast faces, as well as noticing a UDP multicast face being initalized twice. This likely occurs from changing IP addresses in the program's setup, but the error message does not provide much detail. It's also noteworthy that the UDP multi-cast factory seems to be invoked twice for the same interface. An example log is attached below.


Files

log_file_with_debug.txt (17.1 KB) log_file_with_debug.txt Alexander Lane, 08/07/2018 12:31 PM
notes.txt (368 Bytes) notes.txt Alexander Lane, 08/09/2018 01:56 PM
topo.conf (155 Bytes) topo.conf Alexander Lane, 08/09/2018 01:56 PM
exampleexp.py (1017 Bytes) exampleexp.py Alexander Lane, 08/09/2018 01:56 PM
#1

Updated by Davide Pesavento almost 2 years ago

  • Subject changed from Fatal error when initializing multicast faces to Fatal bind error when initializing multicast faces
  • Category changed from Core to Faces
  • Start date deleted (08/07/2018)
#2

Updated by Davide Pesavento almost 2 years ago

  • Assignee set to Davide Pesavento
#3

Updated by Alexander Lane almost 2 years ago

Adding code to replicate and version information if it's needed.

#4

Updated by Davide Pesavento almost 2 years ago

  • Status changed from New to In Progress

I'm trying to debug this with Alexander.
The bind that fails is on sta2-wlan0 with address fe80::ff:fe00:100%sta2-wlan0 (link scope). sta2-wlan0 is an emulated wireless interface using 80211_hwsim.

#5

Updated by Davide Pesavento almost 2 years ago

  • Subject changed from Fatal bind error when initializing multicast faces to Fatal bind error when initializing multicast UDP faces
#6

Updated by Davide Pesavento almost 2 years ago

I could not reproduce the problem on Ubuntu 18.04 using either veth or mac80211_hwsim interfaces. The multicast faces are always created successfully.

Can you test outside mini-ndn (possibly with a simplified setup, e.g. only one pair of mac80211_hwsim interfaces) and see if you still experience the crash?

#7

Updated by Alexander Lane almost 2 years ago

Davide Pesavento wrote:

I could not reproduce the problem on Ubuntu 18.04 using either veth or mac80211_hwsim interfaces. The multicast faces are always created successfully.

Can you test outside mini-ndn (possibly with a simplified setup, e.g. only one pair of mac80211_hwsim interfaces) and see if you still experience the crash?

We are running on 16.04, but I will check on 18.04.

#8

Updated by Davide Pesavento over 1 year ago

Any news?

#9

Updated by Davide Pesavento over 1 year ago

ping

#10

Updated by Davide Pesavento over 1 year ago

  • Status changed from In Progress to Rejected

Also available in: Atom PDF