Project

General

Profile

Task #4812

Check if same coordinate is used by different node

Added by Saurab Dulal over 1 year ago. Updated 9 months ago.

Status:
Closed
Priority:
Normal
Assignee:
Category:
-
Target version:
-
Start date:
01/22/2019
Due date:
% Done:

100%

Estimated time:

Related issues

Is duplicate of mini-ndn - Feature #4711: Check for duplicate hyperbolic coordinates while parsing topology fileNew

Actions

History

#1

Updated by Saurab Dulal over 1 year ago

  • Is duplicate of Feature #4711: Check for duplicate hyperbolic coordinates while parsing topology file added
#2

Updated by Junxiao Shi over 1 year ago

HR coordinates are floating point numbers.
Equality comparison of floating point numbers is generally unreliable.
If comparing them as strings: it’s possible for two different strings to convert to same double due to precision limitation.
Can we specify a minimum difference? For example, either radius or angle must be at least 2-32 apart.

#3

Updated by Saurab Dulal over 1 year ago

Junxiao Shi wrote:

HR coordinates are floating point numbers.
Equality comparison of floating point numbers is generally unreliable.
If comparing them as strings: it’s possible for two different strings to convert to same double due to precision limitation.
Can we specify a minimum difference? For example, either radius or angle must be at least 2-32 apart.

we are reading them as string and checking if they are equal or not, we don't do floating point operation.

#4

Updated by Saurab Dulal 9 months ago

  • Status changed from In Progress to Closed
  • % Done changed from 50 to 100

Also available in: Atom PDF