Project

General

Profile

Bug #5096

TestMulticastEthernetTransport/NetifStateChange fails with interfaces that are not RUNNING

Added by Eric Newberry 2 months ago. Updated 2 months ago.

Status:
Closed
Priority:
Normal
Assignee:
Category:
Faces
Target version:
Start date:
Due date:
% Done:

100%

Estimated time:

Description

On one of the Jenkins agents for macOS Catalina, the Face/TestMulticastEthernetTransport/NetifStateChange consistently fails when it attempts to use the awdl0 (Apple Wireless Direct Link) interface (which is administratively up, but is not RUNNING). However, I have confirmed that it still fails on macOS when this test case attempts to use a standard Ethernet interface that is also administratively up, but not RUNNING.
Davide and I have determined that this issue is likely caused by a combination of the following two issues:

  • EthernetTransport is not initially set to TransportState::DOWN when the underlying interface is initially not InterfaceState::RUNNING.
  • EthernetFixture uses any interface that is administratively up but not necessarily InterfaceState::RUNNING, while the test case in question assumes that the transport is initially TransportState::UP (not guaranteed once the previous point is fixed).

Related issues

Related to NFD - Bug #5074: Transport tests failing due to macOS AWDL interfacesNew

Actions
#1

Updated by Eric Newberry 2 months ago

  • Subject changed from TestMulticastEthernetTransport/NetifStateChange fails on macOS with DOWN interfaces to TestMulticastEthernetTransport/NetifStateChange fails on macOS with administratively up interfaces
  • Description updated (diff)
#2

Updated by Davide Pesavento 2 months ago

  • Subject changed from TestMulticastEthernetTransport/NetifStateChange fails on macOS with administratively up interfaces to TestMulticastEthernetTransport/NetifStateChange fails on macOS with interfaces that are not RUNNING
  • Description updated (diff)
#3

Updated by Davide Pesavento 2 months ago

  • Related to Bug #5074: Transport tests failing due to macOS AWDL interfaces added
#4

Updated by Eric Newberry 2 months ago

  • Status changed from New to In Progress
#5

Updated by Eric Newberry 2 months ago

  • Status changed from In Progress to Code review
  • % Done changed from 0 to 100
#6

Updated by Davide Pesavento 2 months ago

  • Subject changed from TestMulticastEthernetTransport/NetifStateChange fails on macOS with interfaces that are not RUNNING to TestMulticastEthernetTransport/NetifStateChange fails with interfaces that are not RUNNING
  • Category changed from Unit Tests to Faces

FTR, this isn't macOS-specific, it could happen on Linux as well. We've never seen it on Jenkins Linux agents because none of them has a network configuration that triggers the bug.

#7

Updated by Davide Pesavento 2 months ago

  • Status changed from Code review to Closed

Also available in: Atom PDF