Project

General

Profile

Bug #1875

NRD: disable face id checking

Added by Alex Afanasyev about 5 years ago. Updated about 5 years ago.

Status:
Closed
Priority:
High
Assignee:
Category:
RIB
Target version:
Start date:
08/16/2014
Due date:
% Done:

100%

Estimated time:

Description

As we discussed during Friday 15, 2014 meeting, FaceId checking is broken in NRD. I thought the problem is not that prominent, but apparently there are serious problems because NRD's understanding about valid faces is very different from NFDs.

This is part of nfd-autoreg log, after I tried to restart nfd-autoreg:

FAILED: register /ndn/broadcast on face 258 (code: 410, reason: Face not found)
FAILED: register /ndn/guest on face 258 (code: 410, reason: Face not found)
FAILED: register /ndn/edu/ucla on face 258 (code: 410, reason: Face not found)

And this is output from nfd-status:

root@spurs:~# nfd-status -f
Faces:
  ...
  faceid=258 remote=udp6://[2a03:ca81:1200:4:1234:1234:879b:6f49]:6363 local=udp6://[2607:f010:3f9::11:0]:6363 expires=1052s counters={in={23759i 0d 1156598B} out={0i 22300d 9064135B}} on-demand
  ...

I'm proposing to remove the check ASAP and implement #1744 as part of version 0.2 release.


Related issues

Related to NLSR - Task #1876: Periodically check if `Adjacency::m_faceId` is validClosed2014-08-16

History

#1 Updated by Alex Afanasyev about 5 years ago

I suspect that this may be the reason why NLSR was failing after being restarted. At least the error was exactly the same.

#2 Updated by Alex Afanasyev about 5 years ago

  • Related to Task #1876: Periodically check if `Adjacency::m_faceId` is valid added

#3 Updated by Vince Lehman about 5 years ago

  • Status changed from New to Code review
  • % Done changed from 0 to 90

#4 Updated by Junxiao Shi about 5 years ago

  • Status changed from Code review to Closed
  • % Done changed from 90 to 100

Also available in: Atom PDF