Project

General

Profile

Bug #1944

Allow trailing slash for UDP and TCP FaceUris

Added by Vince Lehman about 7 years ago. Updated about 7 years ago.

Status:
Closed
Priority:
Normal
Category:
Management
Target version:
Start date:
08/28/2014
Due date:
% Done:

100%

Estimated time:
1.00 h

Description

Currently, NLSR will not install an entry for a router with a face-uri that has a trailing slash.
e.g. face-uri udp://click.caida.org/

This fix should allow a user to configure the face-uri with or without the trailing slash.

#1

Updated by Alex Afanasyev about 7 years ago

This is not NLSR bug and I will move it to NFD>

Technically, '/' is not allowed in any of the defined FaceURIs (http://redmine.named-data.net/projects/nfd/wiki/FaceMgmt#FaceUri).

On the other hand, NFD should not reject such URIs, since they are technically equivalent.

#2

Updated by Alex Afanasyev about 7 years ago

  • Project changed from NLSR to NFD
  • Category set to Management
  • Status changed from New to In Progress
  • Assignee changed from Vince Lehman to Alex Afanasyev
  • Target version set to v0.3
  • Estimated time set to 1.00 h

To reproduce the problem:

nfdc create udp://1.1.1.1/

Expected: face created

Actual:

[cawka@cawka-mac ~]$ nfdc create udp4://1.1.1.1/
ERROR: Face creation failed: Invalid URI (code: 408)

The problem boils down to the check in daemon/face/[udp|tcp]-factory.cpp

if (!uri.getPath().empty())

I will update factories to allow path that contain just /.

#3

Updated by Alex Afanasyev about 7 years ago

  • Subject changed from Allow trailing slash in face-uri in nlsr.conf to Allow trailing slash for UDP and TCP FaceUris
#4

Updated by Alex Afanasyev about 7 years ago

  • Status changed from In Progress to Code review
  • % Done changed from 0 to 100
#5

Updated by Junxiao Shi about 7 years ago

  • Status changed from Code review to Closed

Also available in: Atom PDF