Project

General

Profile

Bug #2206

NameServer's validator cannot fetch certificate when it gets Update message

Added by Shock Jiang almost 7 years ago. Updated almost 7 years ago.

Status:
Closed
Priority:
High
Assignee:
Target version:
Start date:
11/20/2014
Due date:
% Done:

0%

Estimated time:

Description

when name-server get updates message, its validator cannot fetch necessary certificate, which leads the failure of the name server.

#1

Updated by Alex Afanasyev almost 7 years ago

By "failure" you mean termination because of the thrown exception? In any case this needs to be handled properly (and test case should be added to catch the problem).

#2

Updated by Alex Afanasyev almost 7 years ago

  • Target version set to 0.1
#3

Updated by Shock Jiang almost 7 years ago

  • Status changed from New to Code review
#4

Updated by Junxiao Shi almost 7 years ago

What's the root cause of this issue?

#5

Updated by Shock Jiang almost 7 years ago

NFD does not to forward Interests to the face it was received from. If the name server and its validator share same face, the validator cannot be forwarded to the name server itself

#6

Updated by Shock Jiang almost 7 years ago

Alex Afanasyev wrote:

By "failure" you mean termination because of the thrown exception? In any case this needs to be handled properly (and test case should be added to catch the problem).

by failure I mean the Update message cannot pass verification. Thus, name server just ignores this Update.

#7

Updated by Shock Jiang almost 7 years ago

Shock Jiang wrote:

Alex Afanasyev wrote:

By "failure" you mean termination because of the thrown exception? In any case this needs to be handled properly (and test case should be added to catch the problem).

by failure I mean the Update message cannot pass verification. Thus, name server just ignores this Update. No exception will be shrown.

#8

Updated by Shock Jiang almost 7 years ago

  • Tracker changed from Task to Bug
#9

Updated by Shock Jiang almost 7 years ago

  • Status changed from Code review to Closed

Also available in: Atom PDF