Project

General

Profile

Bug #2360

Multiple scenarios: ERROR: error while connecting to the forwarder (No such file or directory)

Added by Junxiao Shi almost 7 years ago. Updated almost 7 years ago.

Status:
Closed
Priority:
High
Category:
Integration Tests
Target version:
Start date:
01/08/2015
Due date:
% Done:

100%

Estimated time:
3.00 h

Description

Multiple integration test scenarios are failing.

Output contains ERROR: error while connecting to the forwarder (No such file or directory).

Probable cause:

  • In nfd.conf, face_system.unix.listen option is deleted, but some scenarios are specifying this option.
  • In client.conf, unix_socket option is replaced by transport, but some scenarios are specifying the old option.

Files

run.log (43.4 KB) run.log integration tests log Junxiao Shi, 01/08/2015 05:26 PM

Related issues

Related to NFD - Bug #2188: FaceManager creates UnixStreamChannel when listen=noClosed11/17/2014

Actions
Related to ndn-cxx - Feature #2189: Pick Transport type with client.confClosed

Actions
Blocked by NFD - Bug #2387: ndn-autoconfig: FaceCreateCommand uses non-canonical FaceUriClosedHila Ben Abraham01/15/2015

Actions
#1

Updated by Junxiao Shi almost 7 years ago

  • Related to Bug #2188: FaceManager creates UnixStreamChannel when listen=no added
#2

Updated by Junxiao Shi almost 7 years ago

  • Related to Feature #2189: Pick Transport type with client.conf added
#3

Updated by Anonymous almost 7 years ago

I don't know anything about the integration tests and already have my hands full. Please assign this task to someone else.

#4

Updated by Alex Afanasyev almost 7 years ago

Most likely, you have customized client.conf with old format of unix_socket variable (we had it here on one of the machines). We should better handle transition to the new format, as it is not obvious what the problem is.

#5

Updated by Junxiao Shi almost 7 years ago

  • Assignee changed from Anonymous to Hila Ben Abraham

@Hila has some experience with integration tests.

I see both face_system.unix.listen and unix_socket in integration tests code, so I assume the failures are caused by both problems.

#6

Updated by Hila Ben Abraham almost 7 years ago

  • Status changed from New to In Progress

I'm looking into it and I see that 3 tests fail:

  1. Interest loop test fails to connect to the forwarder, probably because it uses its own copy of nfd.conf.
    Another problem with this test is that it reports PASSED at the end rather than FAILED. I believe it should be fixed as well. I'm not sure if you want to open a new bug for it since it contains some structural changes to the code. I believe it would be better to solve it separately but it's your call.

  2. local host test also fails to connect to the forwarder. I can see in the code that the script modifies unix_socket in client.conf. Here, the script correctly reports on its failure.

  3. NDN hub discovery fails because it tries to create Non-canonical face.

I don't know how often you choose to run the integration tests, but I think it should be automated to run once a week or two. I can help building such an automation if you agree it's necessary. If automation is not possible due to the required resources, then maybe we can mark potential tasks/bugs as 'regression required' on redmine and then manually run the tests as part of the code-review process. I think it would be helpful to do it on a major commit such as a new feature or an infrastructure change.

#7

Updated by Junxiao Shi almost 7 years ago

Another problem with Interest loop test is that it reports PASSED at the end rather than FAILED. I believe it should be fixed as well. I'm not sure if you want to open a new bug for it since it contains some structural changes to the code. I believe it would be better to solve it separately but it's your call.

Report a separate Bug under Category=Tests.

I don't know how often you choose to run the integration tests, but I think it should be automated to run once a week or two.

Automation is certainly possible and is quite easy on Emulab. I should enable it once this Bug is fixed.

#8

Updated by Junxiao Shi almost 7 years ago

  • Blocked by Bug #2387: ndn-autoconfig: FaceCreateCommand uses non-canonical FaceUri added
#9

Updated by Hila Ben Abraham almost 7 years ago

  • Status changed from In Progress to Code review
  • % Done changed from 0 to 100
#10

Updated by Junxiao Shi almost 7 years ago

  • Status changed from Code review to Closed

Also available in: Atom PDF