Project

General

Profile

Bug #2405

Broken link to documentation in NFD status web page

Added by Davide Pesavento almost 7 years ago. Updated over 6 years ago.

Status:
Closed
Priority:
Normal
Category:
Tools
Target version:
Start date:
Due date:
% Done:

100%

Estimated time:
1.00 h

Description

  1. Go to the NFD status page of any testbed node
  2. Click on the "Powered by NFD version ..." link on the bottom right of the page -> currently points to http://named-data.net/doc/NFD/0.2.0-88-gc5173de/
  3. Page not found
#1

Updated by Davide Pesavento almost 7 years ago

The link should simply point to http://named-data.net/doc/NFD/current/ I guess.

#2

Updated by Junxiao Shi almost 7 years ago

  • Description updated (diff)
  • Category set to Tools
  • Target version set to v0.3
  • Estimated time set to 1.00 h

Confirmed on Arizona HUB.

Changing to 'current' would cause release version to link to 'current' as well, which is undesirable.

I suggest setting up the webserver of named-data.net so that GET requests to unknown NFD versions are permanently redirected (HTTP 301) to 'current'.

An alternate is to retain every version of docs.
Storage should be no problem.
But I don't recommend this because it's harmful in terms of search engine optimization.

#3

Updated by Alex Afanasyev almost 7 years ago

  • Assignee set to Alex Afanasyev

I will point just to current documentation http://named-data.net/doc/NFD/ and keep the current version number. This will match the practice in gerrit, doxygen, sphinx, and other existing systems.

#4

Updated by Alex Afanasyev almost 7 years ago

  • Status changed from New to Code review
  • % Done changed from 0 to 100
#5

Updated by Junxiao Shi over 6 years ago

  • Status changed from Code review to Resolved

@Davide, please verify that the Bug is resolved.

#6

Updated by Davide Pesavento over 6 years ago

  • Status changed from Resolved to Closed

Confirmed fixed.

Also available in: Atom PDF