Project

General

Profile

Bug #2736

repo-ng cannot set the max-packets to a large number

Added by Chengyu Fan about 4 years ago. Updated almost 4 years ago.

Status:
Closed
Priority:
Normal
Assignee:
-
Target version:
-
Start date:
04/08/2015
Due date:
% Done:

100%

Estimated time:

Description

how to reproduce:

  1. set the the max-packets to 9999999999

  2. run "sudo ndn-repo-ng"

ndn-repo-ng report error "ERROR: conversion of data to type "i" failed".
It is suspect this is caused by "src/repo.cpp: repoConfig.nMaxPackets = repoConf.get("storage.max-packets");"

History

#1 Updated by Shuo Chen about 4 years ago

  • Status changed from New to Code review

#2 Updated by Junxiao Shi about 4 years ago

The config of ndn-cxx on ubuntu 32bit seems wrong

In http://jenkins.named-data.net/job/repo-ng/471/OS=Ubuntu-14.04-32bit/console, /usr/local/lib32/pkgconfig/libndn-cxx.pc is successfully installed.

repo-ng is unable to find ndn-cxx because neither build script nor wscript adds /usr/local/lib32/pkgconfig into PKG_CONFIG_PATH environment variable.

#3 Updated by Alex Afanasyev almost 4 years ago

  • Status changed from Code review to Closed
  • % Done changed from 0 to 100

Also available in: Atom PDF