Project

General

Profile

Task #4743

Deploy macOS 10.14 Jenkins agents

Added by Davide Pesavento 4 months ago. Updated about 1 month ago.

Status:
In Progress
Priority:
Normal
Category:
Build
Target version:
Start date:
Due date:
% Done:

100%

Estimated time:

History

#1 Updated by Davide Pesavento 4 months ago

  • Subject changed from Jenkins macOS 10.14 agents to Deploy macOS 10.14 Jenkins agents

#2 Updated by Junxiao Shi 3 months ago

  • Assignee set to Md Ashiqur Rahman

I notice that macOS 10.12 and macOS 10.13 slaves were incorrectly labelled as "OSX". The name "OSX" is no longer used after OSX 10.11. Be sure not to repeat the same mistake this time.

#3 Updated by Md Ashiqur Rahman 3 months ago

Um, Eric never deployed a MacOS agent and I also don't know the deployment and maintenance procedure. How much different or difficult is it compared to other agents? Need Alex's help.

#4 Updated by Davide Pesavento 3 months ago

Junxiao Shi wrote:

I notice that macOS 10.12 and macOS 10.13 slaves were incorrectly labelled as "OSX". The name "OSX" is no longer used after OSX 10.11.

Nobody cares that Apple changed the marketing name of their operating system. We use "OSX" in the NODE_LABELS config variable and I see no good reason to change that, it would be a waste of time and effort. Even Travis still uses "osx" and "osx_image" in the configuration file. I'm against changing anything in this regard, let's spend our energy in a more productive way.

Be sure not to repeat the same mistake this time.

Please use a different tone when expressing your personal opinion.

#5 Updated by Alex Afanasyev 3 months ago

Completely agree with Davide. It is already an extreme challenge to keep macOS/OSX slaves on, wasting time on renaming backend system elements is completely unnecessary.

#6 Updated by Junxiao Shi 3 months ago

I don't know the deployment and maintenance procedure. How much different or difficult is it compared to other agents?

The scripts are there: https://github.com/cawka/ndn-jenkins-slaves
However, how to generate the images such as ndn-jenkins/osx-10.13 aren't documented.

The easiest for this and all future macOS deployment would be using a cloud service.
It's not cheap, but saved labor and reduced developer frustration can more than justify the cost.

#7 Updated by Md Ashiqur Rahman 3 months ago

Thanks. We have Monaco (Mac mini from 2012) lying around. I'll use that as the host.

#8 Updated by Junxiao Shi 3 months ago

monaco has 4GB of RAM so it can fit only one VM. You still should use a VM (and not build on physical machine) to ensure easy recovery.
To get full redundancy: place one set of macOS 10.12-10.14 among monaco and mavericks, and place another set at CSU. Any one node failure would not take out all slaves for an OS.

#9 Updated by Md Ashiqur Rahman 3 months ago

We upgrded the machine with 16gb memory. 2 VMs should run easily.

#10 Updated by Alex Afanasyev 3 months ago

The scripts are there: https://github.com/cawka/ndn-jenkins-slaves
However, how to generate the images such as ndn-jenkins/osx-10.13 aren't documented.

run 10.13, upgrade to 14, package box per vagrant instructions. Nothing really to document.

#11 Updated by Md Ashiqur Rahman 3 months ago

I'm getting the following error trying to get Alex's 10.13 box:

The box you're attempting to add doesn't support the provider
you requested. Please find an alternate box or use an alternate
provider. Double-check your requested provider to verify you didn't
simply misspell it.

If you're adding a box from HashiCorp's Vagrant Cloud, make sure the box is
released.

Name: ndn-jenkins/osx-10.13
Address: https://vagrantcloud.com/ndn-jenkins/osx-10.13
Requested provider: [:virtualbox]

#12 Updated by Md Ashiqur Rahman 3 months ago

Got one 10.14 vm up and running, testing with NFD, ndn-cxx. I've uploaded a 10.14 box to Vagrant Cloud and use this Vagrantfile to deploy vm.

#13 Updated by Davide Pesavento 3 months ago

  • Status changed from New to In Progress
  • % Done changed from 0 to 50

#14 Updated by Davide Pesavento 2 months ago

what's the status here?

#15 Updated by Md Ashiqur Rahman 2 months ago

Both, broke. I'll cleanup and set two 10.14 at UA now.

#16 Updated by Md Ashiqur Rahman 2 months ago

2 vms are up and running, successfully tested with NFD, ndn-cxx and ndn-tools. Added to these three.

#17 Updated by Junxiao Shi about 2 months ago

I notice that both macOS 10.14 slaves (as well as macOS 10.13) are deployed on the same site. They need to be swapped to fulfill resiliency requirements and prevent downtime due to single site failure.

#18 Updated by Davide Pesavento about 1 month ago

Junxiao Shi wrote:

I notice that both macOS 10.14 slaves (as well as macOS 10.13) are deployed on the same site.

A 10.14 slave has been deployed at FIU. However, 10.13 is still available at only one site (UCLA).

#19 Updated by Junxiao Shi about 1 month ago

  • Status changed from In Progress to Closed
  • % Done changed from 50 to 100

#4301 reopened for 10.13

#20 Updated by Davide Pesavento about 1 month ago

  • Status changed from Closed to In Progress

Let's not close this until Ashiq has confirmed that 10.14 has been enabled for all relevant projects.

Also available in: Atom PDF