Project

General

Profile

Bug #4907

ndnsec-list: -K and -C flags

Added by Junxiao Shi almost 2 years ago. Updated almost 2 years ago.

Status:
Closed
Priority:
Low
Category:
Tools
Target version:
Start date:
Due date:
% Done:

100%

Estimated time:
0.50 h

Description

ndnsec-list manpages list -K as an alias of -k, -C as an alais of -c. However, the program does not accept them.
Either the manpage or the program must be updated.

#1

Updated by Davide Pesavento almost 2 years ago

  • Assignee set to Davide Pesavento
  • Start date deleted (04/03/2019)
#2

Updated by Davide Pesavento almost 2 years ago

  • Status changed from New to Code review
  • Priority changed from Normal to Low
  • % Done changed from 0 to 100
#3

Updated by Junxiao Shi almost 2 years ago

I'm unable to build documentation from 5398,2 on Ubuntu 16.04.
I notice that CI script is not invoking ./waf docs, which explains why CI did not catch this error.

Console output:

$ ./waf docs
'docs' finished successfully (0.000s)
Waf: Entering directory `/users/jns23/code/ndn-cxx-dev/build'
[1/3] Compiling docs/doxygen.conf.in
[2/3] Compiling docs/named_data_theme/named_data_footer-with-analytics.html.in
[3/3] Processing build/docs/doxygen.conf
Waf: Leaving directory `/users/jns23/code/ndn-cxx-dev/build'
'doxygen' finished successfully (43.363s)
Waf: Entering directory `/users/jns23/code/ndn-cxx-dev/build'
[1/1] Processing sphinx_build [html]: docs/INSTALL.rst docs/RELEASE_NOTES.rst docs/code-style.rst docs/examples.rst docs/index.rst docs/manpages/ndn-client.conf.rst docs/manpages/ndn-log.rst docs/manpages/ndnsec-cert-dump.rst docs/manpages/ndnsec-cert-gen.rst docs/manpages/ndnsec-cert-install.rst docs/manpages/ndnsec-delete.rst docs/manpages/ndnsec-export.rst docs/manpages/ndnsec-get-default.rst docs/manpages/ndnsec-import.rst docs/manpages/ndnsec-key-gen.rst docs/manpages/ndnsec-list.rst docs/manpages/ndnsec-set-default.rst docs/manpages/ndnsec-sign-req.rst docs/manpages/ndnsec-unlock-tpm.rst docs/manpages/ndnsec.rst docs/manpages.rst docs/release-notes/release-notes-0.1.0.rst docs/release-notes/release-notes-0.2.0.rst docs/release-notes/release-notes-0.3.0.rst docs/release-notes/release-notes-0.3.1.rst docs/release-notes/release-notes-0.3.2.rst docs/release-notes/release-notes-0.3.3.rst docs/release-notes/release-notes-0.3.4.rst docs/release-notes/release-notes-0.4.0.rst docs/release-notes/release-notes-0.4.1.rst docs/release-notes/release-notes-0.5.0.rst docs/release-notes/release-notes-0.5.1.rst docs/release-notes/release-notes-0.6.0.rst docs/release-notes/release-notes-0.6.1.rst docs/release-notes/release-notes-0.6.2.rst docs/release-notes/release-notes-0.6.3.rst docs/release-notes/release-notes-0.6.5.rst docs/release-notes-latest.rst docs/releases.rst docs/specs/certificate-format.rst docs/specs/safe-bag.rst docs/specs/signed-interest.rst docs/specs/validation-error-code.rst docs/specs.rst docs/tutorials/security-validator-config.rst docs/tutorials/utils-ndn-regex.rst docs/tutorials.rst docs/conf.py -> build/docs


Exception occurred:
  File "/usr/local/lib/python3.5/dist-packages/sphinxcontrib/doxylink/doxylink.py", line 209, in create_role
    app.info(bold('Checking tag file cache for %s: ' % cache_name), nonl=True)
AttributeError: 'Sphinx' object has no attribute 'info'
The full traceback has been saved in /tmp/sphinx-err-x4mmq3qh.log, if you want to report the issue to the developers.
Please also report this if it was a user error, so that a better error message can be provided next time.
A bug report can be filed in the tracker at <https://github.com/sphinx-doc/sphinx/issues>. Thanks!

Waf: Leaving directory `/users/jns23/code/ndn-cxx-dev/build'
Build failed
 -> task in '' failed with exit status 2 (run with -v to display more information)

Stacktrace:

# Sphinx version: 2.0.1
# Python version: 3.5.2 (CPython)
# Docutils version: 0.14 
# Jinja2 version: 2.10.1
# Last messages:

# Loaded extensions:
Traceback (most recent call last):
  File "/usr/local/lib/python3.5/dist-packages/sphinx/cmd/build.py", line 283, in build_main
    args.tags, args.verbosity, args.jobs, args.keep_going)
  File "/usr/local/lib/python3.5/dist-packages/sphinx/application.py", line 260, in __init__
    self._init_builder()
  File "/usr/local/lib/python3.5/dist-packages/sphinx/application.py", line 321, in _init_builder
    self.emit('builder-inited')
  File "/usr/local/lib/python3.5/dist-packages/sphinx/application.py", line 440, in emit
    return self.events.emit(event, self, *args)
  File "/usr/local/lib/python3.5/dist-packages/sphinx/events.py", line 76, in emit
    results.append(callback(*args))
  File "/usr/local/lib/python3.5/dist-packages/sphinxcontrib/doxylink/doxylink.py", line 277, in setup_doxylink_roles
    app.add_role(name, create_role(app, tag_filename, rootdir))
  File "/usr/local/lib/python3.5/dist-packages/sphinxcontrib/doxylink/doxylink.py", line 209, in create_role
    app.info(bold('Checking tag file cache for %s: ' % cache_name), nonl=True)
AttributeError: 'Sphinx' object has no attribute 'info'

Package versions:

Successfully installed Jinja2-2.10.1 MarkupSafe-1.1.1 Pygments-2.3.1 alabaster-0.7.12 babel-2.6.0 docutils-0.14 imagesize-1.1.0 packaging-19.0 pyparsing-2.4.0 pytz-2019.1 snowballstemmer-1.2.1 sphinx-2.0.1 sphinxcontrib-applehelp-1.0.1 sphinxcontrib-devhelp-1.0.1 sphinxcontrib-doxylink-1.6 sphinxcontrib-googleanalytics-0.1 sphinxcontrib-htmlhelp-1.0.1 sphinxcontrib-jsmath-1.0.1 sphinxcontrib-qthelp-1.0.2 sphinxcontrib-serializinghtml-1.1.3
#4

Updated by Davide Pesavento almost 2 years ago

Doesn't seem to be caused by (or even related to) my commit. I think it's an incompatibility between the new sphinx-2.0 and the doxylink extension... it wouldn't be the first time that doxylink breaks. Using sphinx-1.7.9 works for me.

#5

Updated by Alex Afanasyev almost 2 years ago

This is a compatibility problem with doxylink. The fix seem to be pushed to the upstream, but there is no package published... You can try to install sphinxcontrib-doxylink-hotfix as a temporary replacement package (I pushed it), worked for me.

#6

Updated by Junxiao Shi almost 2 years ago

Using sphinx-1.7.9 works for me.

Please update README-dev.md with proper instructions.

You can try to install sphinxcontrib-doxylink-hotfix as a temporary replacement package

Unable to install.

~$ sudo pip3 install -U sphinxcontrib-doxylink-hotfix
Collecting sphinxcontrib-doxylink-hotfix
  Could not find a version that satisfies the requirement sphinxcontrib-doxylink-hotfix (from versions: )
No matching distribution found for sphinxcontrib-doxylink-hotfix
#7

Updated by Junxiao Shi almost 2 years ago

Not sure what you want from me. Use an older version as I already said, or uninstall sphinxcontrib-doxylink (it's not used in manpages). The failure isn't caused by this commit but is pre-existing, and it's not even our fault, it's an incompatibility in another package.

The commands to install "an older version" need to appear in README-dev.md, replacing the incorrect command that result in compilation failure.

#8

Updated by Davide Pesavento almost 2 years ago

  • Status changed from Code review to Closed

Also available in: Atom PDF