Project

General

Profile

Bug #5013

FIFO cs policy: QUEUE_FIFO eventually starves other queues

Added by Ernest McCracken 8 months ago. Updated 8 months ago.

Status:
Rejected
Priority:
Normal
Assignee:
-
Category:
Tables
Target version:
-
Start date:
09/30/2019
Due date:
% Done:

0%

Estimated time:

Description

FIFO has 3 queues QUEUE_FIFO, QUEUE_STALE, and QUEUE_UNSOLICITED. When the cache is full it begins to evict from QUEUE_UNSOLICITED, then QUEUE_STALE, and finally QUEUE_FIFO. Eventually QUEUE_FIFO will starve other queues.

For instance, if QUEUE_FIFO is filled to the cs limit. When an unsolicited data packet comes it in will evict one cs entry from QUEUE_FIFO. However, when another unsolicited data packet comes in the policy will see one entry in QUEUE_UNSOLICITED and evict it. Once QUEUE_FIFO is filled the policy will only allow one entry in any other lower priority queue until the CS is cleared.

#1

Updated by Junxiao Shi 8 months ago

This behavior is by design.
priority_fifo is no longer recommended for general usage. LRU is much better.

#2

Updated by Davide Pesavento 8 months ago

  • Status changed from New to Rejected

Also available in: Atom PDF