Project

General

Profile

Bug #1908

nfd-start fails to start daemon (best-route strategy patch refs/changes/66/1166/4)

Added by Peter Gusev almost 6 years ago. Updated almost 6 years ago.

Status:
Closed
Priority:
Normal
Assignee:
Category:
-
Target version:
Start date:
08/22/2014
Due date:
% Done:

0%

Estimated time:

Description

Steps to reproduce:

On a clean machine:

  • Install NFD:
    • Install ndn-cxx:
      • prerequisites:
        • install mac ports
        • install Xcode developer tools
        • sudo port install pkgconfig boost sqlite3 libcryptopp
      • git clone https://github.com/named-data/ndn-cxx.git
      • Switch ndn-cxx branch: git checkout release-0.2.0
      • ./waf configure
      • ./waf
      • sudo ./waf install
    • mkdir NFD && cd NFD && git init .
    • git fetch http://gerrit.named-data.net/NFD refs/changes/66/1166/4 && git checkout FETCH_HEAD
    • git submodule init && git submodule update
    • export PKG_CONFIG_PATH=/opt/local/lib/pkgconfig:/usr/local/lib/pkgconfig:/usr/lib/pkgconfig:$PKG_CONFIG_PATH
    • ./waf configure
    • ./waf
    • sudo ./waf install
  • Configure NFD:
    • ndnsec-keygen /whoami| ndnsec-install-cert -
    • sudo cp /usr/local/etc/ndn/nfd.conf.sample /usr/local/etc/ndn/nfd.conf
  • Run NFD:
    • nfd-start

Result:

remap$ nfd-start
1408733340.019637 INFO: [StrategyChoice] Set default strategy /localhost/nfd/strategy/best-route
1408733340.019784 INFO: [StrategyChoiceEntry] Set strategy /localhost/nfd/strategy/best-route for / prefix
1408733340.020196 INFO: [InternalFace] registering callback for /localhost/nfd/fib
1408733340.020344 INFO: [InternalFace] registering callback for /localhost/nfd/faces
1408733340.020472 INFO: [InternalFace] registering callback for /localhost/nfd/strategy-choice
1408733340.020688 INFO: [InternalFace] registering callback for /localhost/nfd/status
1408733340.021000 INFO: [FaceTable] Added face id=1 remote=internal:// local=internal://
1408733341.699209 WARNING: [CommandValidator] Wildcard identity is intended for demo purpose only and SHOULD NOT be used in production environment
1408733341.699409 INFO: [CommandValidator] Giving privilege "faces" to identity wildcard
1408733341.699514 INFO: [CommandValidator] Giving privilege "fib" to identity wildcard
1408733341.699584 INFO: [CommandValidator] Giving privilege "strategy-choice" to identity wildcard
1408733341.699923 INFO: [TablesConfigSection] Setting CS max packets to 65536
1408733341.712128 INFO: [MulticastUdpFace] Creating multicast UDP face for group 224.0.23.170:56363
1408733341.712297 INFO: [FaceTable] Added face id=256 remote=udp4://224.0.23.170:56363 local=udp4://10.10.0.1:56363
1408733341.745629 INFO: [MulticastUdpFace] Creating multicast UDP face for group 224.0.23.170:56363
1408733341.745796 INFO: [FaceTable] Added face id=257 remote=udp4://224.0.23.170:56363 local=udp4://128.97.152.54:56363
1408733341.770806 INFO: [MulticastUdpFace] Creating multicast UDP face for group 224.0.23.170:56363
1408733341.770939 INFO: [FaceTable] Added face id=258 remote=udp4://224.0.23.170:56363 local=udp4://127.0.0.1:56363
1408733341.792983 INFO: [EthernetFace] Creating ethernet face on en0: c8:bc:c8:97:4f:c1 <--> 01:00:5e:00:17:aa
1408733341.793731 FATAL: [NFD] assign: Invalid argument
1408733342.012186 INFO: [RibManager] Listening on: /localhost/nfd/rib
1408733342.042348 INFO: [RibManager] Start monitoring face create/destroy events
1408733342.065270 FATAL: [NRD] error while connecting to the forwarder (No such file or directory)


Related issues

Is duplicate of NFD - Bug #1877: EthernetFace creation fails on OS X with Boost 1.56.0ClosedAlex Afanasyev08/17/2014

Actions
#1

Updated by Jeff Burke almost 6 years ago

This looks like this bug, if you are running Boost 1.56 on that machine.
http://redmine.named-data.net/issues/1877

Try disabling the ethernet multicast face in the NFD configuration file.

#2

Updated by Peter Gusev almost 6 years ago

Confirmed, disabling ether multicast helps.
Closing this ticket as a duplicate for http://redmine.named-data.net/issues/1877

#3

Updated by Junxiao Shi almost 6 years ago

  • Is duplicate of Bug #1877: EthernetFace creation fails on OS X with Boost 1.56.0 added
#4

Updated by Junxiao Shi almost 6 years ago

  • Status changed from New to Closed

Also available in: Atom PDF