Project

General

Profile

Feature #3813

Forwarding strategy for using multiple interfaces in generic deployments

Added by Jeff Burke over 2 years ago. Updated about 2 years ago.

Status:
Duplicate
Priority:
Normal
Assignee:
-
Category:
-
Target version:
-
Start date:
10/16/2016
Due date:
% Done:

0%

Estimated time:

Description

Deployers of NDN applications at the edge do not currently have a default or generic forwarding strategy to use that leverages multiple interfaces available on edge devices. Memphis has proposed SRTT forwarding might be used for this. An implementation is needed for testing in applications.


Related issues

Is duplicate of NFD - Feature #3566: Adaptive Forwarding Strategy for hyperbolic routingClosed

History

#1 Updated by Lan Wang over 2 years ago

Our ASF strategy has been implemented in NFD and is part of the latest NFD release (0.5.0). Here's the related Redmine issue: https://redmine.named-data.net/issues/3566. I hope John will deploy the latest NFD soon on the testbed (or maybe he has deployed it). Since the ASF strategy (and any other NFD strategy) uses faces registered in the FIB as candidates for its probing/measurement, you will need to insert those interfaces into the FIB in some way. In routers, the population of the FIB is automatically done by the routing protocol (NLSR), but in end host you will probably need to do it in some other module (it's best to ask Junxiao/Alex what's the best way to do this).

#2 Updated by Junxiao Shi about 2 years ago

  • Related to Feature #3566: Adaptive Forwarding Strategy for hyperbolic routing added

#3 Updated by Junxiao Shi about 2 years ago

  • Related to deleted (Feature #3566: Adaptive Forwarding Strategy for hyperbolic routing)

#4 Updated by Junxiao Shi about 2 years ago

  • Is duplicate of Feature #3566: Adaptive Forwarding Strategy for hyperbolic routing added

#5 Updated by Junxiao Shi about 2 years ago

  • Status changed from New to Duplicate

you will need to insert those interfaces into the FIB in some way.
in end host you will probably need to do it in some other module

#3831 will take care of this step.

Also available in: Atom PDF