Project

General

Profile

Task #4087

Urgent bugs caused by ndn-cxx change 3603

Added by Zhiyi Zhang over 4 years ago. Updated 9 months ago.

Status:
Closed
Priority:
Urgent
Assignee:
Start date:
05/23/2017
Due date:
% Done:

0%

Estimated time:
1.00 h

Description

In the ndn-cxx change 3603 "Remove previously deprecated headers, methods, and constants", we removed a bunch of deprecated headers/methods/constants from ndn-cxx. This change caused urgent bugs in ChronoChat.

To fix the urgent bug, one needs to compile and install the latest commit of ndn-cxx change 3603 and compile ChronoChat and fix all the urgent bugs.

In the ndn-cxx-breaks run (https://travis-ci.org/yoursunny/ndn-cxx-breaks/builds/235341547), some bugs are caused by the missing header identity-certificate.hpp.


Related issues

Blocked by ndn-cxx - Task #3988: Remove deprecated methods, data structures, and enumsClosedAlex Afanasyev03/07/2017

Actions
#1

Updated by Junxiao Shi over 4 years ago

  • Blocked by Task #3988: Remove deprecated methods, data structures, and enums added
#2

Updated by Junxiao Shi over 4 years ago

#3717 #3718 #3719 are part of this.

#3

Updated by Varun Patil 10 months ago

Fixed, please close

#4

Updated by Alex Afanasyev 9 months ago

  • Status changed from New to Closed
  • Assignee set to Varun Patil

Also available in: Atom PDF