Project

General

Profile

Bug #4632

Cannot add route to existing face

Added by Peter Gusev about 2 years ago. Updated over 1 year ago.

Status:
Closed
Priority:
High
Assignee:
-
Category:
gui
Start date:
Due date:
% Done:

100%

Estimated time:

Description

Description

  1. Make sure remote face already exists (for example, udp://10.0.0.1)
  2. Go to "Routes" and add a new route with arbitrary prefix and same remote URI (udp://10.0.0.1).

Result
App fails to add route and displays message:
"Error communicating with NFD (Action failed, forwarder returned: 409 Face with remote URI already exists)"

Expected result
App adds route to the existing face.

Additional info
See screen capture for this bug -- https://youtu.be/Ewh8WhEAqkE.


Related issues

Related to NFD-android - Feature #3997: Support using FaceId in creating a routeClosedJu Pan

Actions
#1

Updated by Davide Pesavento about 2 years ago

  • Subject changed from App prohibits to add route to an existing remote face to Cannot add route to existing face
  • Start date deleted (06/11/2018)

I can confirm this issue.

#2

Updated by Alex Afanasyev about 2 years ago

  • Has duplicate Feature #3997: Support using FaceId in creating a route added
#3

Updated by Junxiao Shi about 2 years ago

  • Has duplicate deleted (Feature #3997: Support using FaceId in creating a route)
#4

Updated by Junxiao Shi about 2 years ago

  • Blocks Feature #3997: Support using FaceId in creating a route added
#5

Updated by Davide Pesavento over 1 year ago

  • Blocks deleted (Feature #3997: Support using FaceId in creating a route)
#6

Updated by Davide Pesavento over 1 year ago

  • Related to Feature #3997: Support using FaceId in creating a route added
#7

Updated by Davide Pesavento over 1 year ago

  • Category set to gui
  • Status changed from New to Closed
  • % Done changed from 0 to 100

This now works for me with NFD-android 0.6.5-1
Please reopen if you still have issues.

Also available in: Atom PDF